Einführung in das VisiWinStudio Archivsystem

Komponenten des Archivsystems

VisiWin Studio


Komponenten des Archivsystems

Archivierungssysteme haben im Allgemeinen die Funktion, Daten zu speichern, um sie zu einem späteren Zeitpunkt darzustellen, bzw. auszuwerten. Die Aufgabe eines Archivierungssystems lässt sich in folgende Funktionen teilen:

Aufgabe | Beschreibung
Auswahl der zu speichernden Daten | Welche Daten sind relevant für eine spätere Auswertung, welche Daten sollen archiviert werden?
Speicherformat | Sollen die Daten als Rohdaten erfasst werden oder ist es sinnvoll, die Daten schon vor dem Speichern vorzubehandeln (Fehlerwertmarkierung, Kompression, Filter...)
Datenorganisation | Wo sollen die Daten abgelegt werden? Ist es sinnvoll, größere Datenmengen in Unterverzeichnissen und Dateien zu verteilen? Auf welches Ereignis soll eine Unterteilung erfolgen?
Anzeige | Wie sollen die Daten angezeigt werden (tabellarisch, Diagramm, zeitlicher Verlauf, x/y-Schreiber...)?
Auswertung | Wo sind markante Punkte in den aufgenommenen Werten (Maximum, Minimum, stochastische Untersuchung)?

Das VisiWinStudio Archivsystem bietet die Möglichkeit, Prozessvariablenwerte mit minimalem Programmieraufwand zu archivieren. Dabei werden die einzelnen Archivieraufgaben von den zum Archivsystem gehörenden Definitionen und Objekten erledigt:

Aufgabe | Definition
Auswahl der zu speichernden Daten | Trend
Speicherformat | Trend
Datenorganisation | Archiv
Anzeige | Steuerelemente VWTrend, VWTrendLegend, VWTrendTime
Auswertung | Steuerelement VWTrend/ Zugriff auf Archivdaten über VWCOMponents-Objekte.

Anhand des folgenden Blockschaltbildes werden die Komponenten des Archivsystems vorgestellt. Weiterführende Informationen über die Komponenten werden als Querverweise angegeben.

Variablenkernel Je nach gewähltem Projekttyp liefert entweder der VWOPC- oder der VW32-Kernel die Prozessdaten zur Aufzeichnung im Archivserver.

(—> Handbücher Projektmanagement/ Prozessanbindung)
Archivserver Während der Initialisierung liest der Archivserver die in der Projektdatenbank festgelegten Definitionen aus. Prozessdaten, die aufzuzeichnen sind, werden beim Variablenkernel zur Überwachung angemeldet, d.h. ändert sich einer dieser Prozesswerte, so wird der Archivserver davon unterrichtet. Dieser speichert dann die Daten als Trenddaten in den Archivdateien ab.

Die Aufzeichnung eines Wertes wird bei Bedarf direkt an die angeschlossenen Client-Applikationen weitergereicht. Damit ist die Onlinedarstellung von Trenddaten möglich. Client-Anforderungen auf historische Trenddaten werden durch das Auslesen der entsprechenden Archivdateien erfüllt.

Applikationssprachabhängige Texte, die zur Darstellung von Zusatzinformationen benötigt werden, fordert der Archivserver aus dem Indextextserver an.
Indextextserver Der Indextextserver liefert dem Archivserver optionale textuelle Zusatzinformationen mit allen Möglichkeiten dynamischer Indextexte. So können Indextexte Prozessvariablenwerte, weitere zustandsbezogene Indextexte und Sonderformate wie Datum, Uhrzeit usw. enthalten.

(—> Handbuch Indextextsystem)
Archivdateien | Die Archivdateien enthalten die Trenddaten. Sie werden vom Archivserver erstellt, gepflegt und verwaltet.
Archivclient Der Archivclient einer Visualisierungsapplikation dient dazu, die Anforderung der Steuerelemente nach Trenddaten an den Archivserver weiterzugeben.

Die Funktionen der VWCOMponents-Objekte werden vom Archivclient an den Archivserver weitergegeben.
Steuerelemente VisiWinStudio ermöglicht die Anzeige von Trenddaten im Steuerelement VWSTrend. Zusätzliche Hilfssteuerelemente unterstützen die Darstellung mit Hilfe von Legenden und Navigierfunktionen.

(—> Handbuch ActiveX-Steuerelemente)
VWCOMponents Diese Objekte ermöglichen den quellcodegesteuerten Zugriff auf Daten des Archivservers.

(—> Handbuch VWCOMponents)
Projektdatenbank Die Projektdatenbank enthält die Definitionen des Archivsystems. Die Festlegung, welcher Prozesswert aufgezeichnet werden soll und wie dieser darzustellen ist, wird in einer Trenddefinition festgelegt.

Archivdefinitionen fassen Trends zu einer Speichereinheit zusammen. Für alle enthaltenen Trenddefinitionen wird gemeinsam bestimmt, wie und wo die Trenddaten gespeichert werden.

(—> Kap. "Definitionen des Archivsystems"/ "Parameter der Definitionen" in diesem Handbuch)
Archiveditor Der Archiveditor ermöglicht die Projektierung des Archivsystems zur Entwicklungszeit. Durch die Festlegung der Definitionen in der Projektdatenbank wird das Laufzeitverhalten des Archivservers bestimmt.

(—> Kap. "Projektierung" in diesem Handbuch)
Eigenschaftenseiten | Die Eigenschaftenseiten ermöglichen die benutzerfreundliche Auswahl von Definitionen aus der Projektdatenbank. zur Entwicklungszeit. Sie sind integraler Bestandteil der VisiWinStudio-Steuerelemente, können aber auch als Komponente bei der Entwicklung eigener Benutzersteuerelemente eingebunden werden. Als Projektierunterstützung für das Archivsystem stellt VisiWinStudio Eigenschaftenseiten zur Auswahl von Trend- und Archivdefinitionen zur Verfügung.


Projektierung

Start des Archiveditors

Komponenten des Archiveditors

Editorfunktionen


Start des Archiveditors

VisiWinStudio stellt einen Editor zum Projektieren der Definitionen des Archivsystems zur Verfügung.

Der Archiveditor wird im VisiWinStudio-Projektexplorer durch das Symbol [image] repräsentiert.

Nach dem erstmaligen Anklicken des Knotens "Archive" initialisiert sich der Editor: Unter dem Knoten "Archive" werden alle bereits in der Projektdatenbank definierten Archivdefinitionen als Unterknoten eingefügt.

Der Tabelleneditor wird über den Shortcut "Alt+F6" oder das Kontextmenü ("Editor anzeigen") einer Archivdefinition im Projektexplorer geöffnet. Der Tabelleneditor stellt die darin enthaltenen Trenddefinitionen dar.


Komponenten des Archiveditors

Archive | Archivdefinitionen werden im Projektexplorer als Einträge unter dem Knoten "Archive" dargestellt. Sie bestimmen das Speicherverhalten von Trenddefinitionen.
Trends | Trenddefinitionen bestimmen, welche Prozessvariablenwerte gespeichert werden sollen. Zusätzlich können Filter- und Ansichtsparameter festgelegt werden.
Statuszeile | Die Statuszeile gibt einen schnellen Überblick über den Inhalt des Archivsystems.
Menüleiste | Die Menüleiste stellt alle nötigen Funktionen zur Bearbeitung von Archiven und Trends zur Verfügung.


Editorfunktionen

Der Archiveditor beinhaltet alle Funktionen zum Editieren der Definitionen des Archivsystems in der Menüleiste des Tabelleneditors. Die Menüs werden in Abhängigkeit von der gerade markierten Definition aktiv oder inaktiv geschaltet. Die Definitionen des Archivsystems befinden sich im Projektexplorer (unter dem Editorzugriffsknoten "Archive") und im Tabelleneditor.

Menü | Aufruf
Archive | Als Kontextmenü auf einem Knoten der entsprechenden Definition oder über das Hauptmenü des Tabelleneditors.
Trends | Als Kontextmenü auf einer Definition im Tabelleneditor oder über das Hauptmenü des Tabelleneditors.
Extras | Sonderfunktionen


Archive

Archivdefinitionen werden im Projektexplorer als Knoten unter dem Hauptzugriffsknoten "Archive" dargestellt. Die Funktionen des Editors beziehen sich auf den gerade im Projektexplorer markierten Knoten. Der Editor beinhaltet zum Editieren von Archiven folgende Funktionen in der Menüleiste:

Neu | Legt eine neue Archivdefinition an.
Bearbeiten | Öffnet den Dialog zum Bearbeiten einer Archivdefinition.
Löschen | Löscht die im Projektexplorer selektierte Archivdefinition mitsamt aller enthaltenen Trends.


Projektierung - Archive - Neu

Neu

Aufruf | Menü: | Archiv—>Neu
 | PopUp Menü: | Klicken auf den Zugriffsknoten "Archive" im VisiWin-Projektexplorer mit rechter Maustaste, anschließend Auswahl des Menüs "Neu".
 | Shortcut: | Klicken auf den Zugriffsknoten "Archive" im VisiWin-Projektexplorer, anschließend Taste F8.
Beschreibung | Eine neue Archivdefinition wird unter dem Zugriffsknoten "Archive" im VisiWin-Projektexplorer eingefügt. Die Einstellung der Archivparameter erfolgt dann über Archiv-> Bearbeiten.


Projektierung - Archive - Bearbeiten

Bearbeiten

Aufruf | Menü: | Archiv—>Bearbeiten
 | PopUp Menü: | Klicken auf eine bestehende Archivdefinition im VisiWin-Projektexplorer mit rechter Maustaste, anschließend Auswahl des Menüs "Bearbeiten".
 | Shortcut: | Klicken auf eine bestehende Archivdefinition im VisiWin-Projektexplorer anschließend Taste F9.
Beschreibung | Der Dialog zum Editieren der im VisiWin-Projektexplorer markierten Archivdefinition wird geöffnet. In diesem Dialog werden die spezifischen Parameter festgelegt (siehe auch Archivdefinition).


Projektierung - Archive - Löschen

Löschen

Aufruf | Menü: | Archiv—>Löschen
 | PopUp Menü: | Klicken auf eine bestehende Archivdefinition im VisiWinStudio-Projektexplorer mit rechter Maustaste, anschließend Auswahl des Menüs "Löschen".
 | Shortcut: | Klicken auf eine bestehende Archivdefinition im VisiWinStudio-Projektexplorer, anschließend Taste "Strg+Entf".
Beschreibung | Die im VisiWinStudio-Projektexplorer markierte Archivdefinition und alle darin enthaltenen Trends werden gelöscht.


Trends

Trenddefinitionen werden im Tabelleneditor als Tabellenzeilen dargestellt. Es werden alle Trenddefinitionen in der Tabelle angezeigt, die sich im gewählten Archiv (im VisiWin-Projektexplorer markierten Archivknoten) befinden.

Die Parameter einer Trenddefinition können direkt in der Tabelle oder im Trenddialog bearbeitet werden. Die Funktionen des Editors beziehen sich auf die Trenddefinition, auf die sich im Tabelleneditor der Cursor befindet, bzw. die Trenddefinitionen, die im Tabelleneditor selektiert sind.

Der Editor beinhaltet zum Editieren von Trends folgende Funktionen:

Neu | Legt eine neue Trenddefinition in der Projektdatenbank an.
Bearbeiten | Öffnet den Dialog zum Bearbeiten einer Trenddefinition.
Löschen | Löscht die selektierten Trenddefinitionen.


Projektierung - Trends - Neu

Neu

Aufruf | Menü: | Trend—>Neu
 | PopUp Menü: | Klicken auf die Trendtabelle im Tabelleneditor mit rechter Maustaste, anschließend Auswahl des Menüs "Neu".
 | Shortcut: | Klicken auf die Trendtabelle im Tabelleneditor, anschließend Taste F8.
Beschreibung | Eine neue Trenddefinition wird in das im VisiWin-Projektexplorer markierte Archiv eingefügt.


Projektierung - Trends - Bearbeiten

Bearbeiten

Aufruf | Menü: | Trend—>Bearbeiten
 | PopUp Menü: | Klicken auf eine Trenddefinition in der Trendtabelle im Tabelleneditor mit rechter Maustaste, anschließend Auswahl des Menüs "Bearbeiten".
 | Shortcut: | Bewegen des Cursors auf eine Trenddefinition in der Trendtabelle im Tabelleneditor, anschließend Taste F9.
Beschreibung | Der Dialog zum Editieren der markierten Trenddefinition wird geöffnet. Trenddefinitionen können direkt im Tabelleneditor oder mit dem Trenddialog bearbeitet werden. Der Trenddialog bietet gegenüber dem Tabelleneditor eine andere Strukturierung der Trendparameter. Die Parameter sind auf vier Karteikarten unterteilt:
 | Standard |  | Legt allgemeine Einstellungen fest.
 | Aufzeichnung |  | Legt das Speicherformat fest.
 | Anzeige |  | Bestimmt, wie die Trenddaten in einem Steuerelement angezeigt werden sollen.
 | Anzeige (Toleranzband) |  | Bestimmt die Darstellung des Toleranzbandes.


Projektierung - Trends - Löschen

Löschen

Aufruf | Selektieren einer oder mehrerer Trenddefinitionen (siehe auch Selektieren von Definitionen).
 | Menü: | Trend—>Löschen
 | PopUp Menü: | Klicken mit rechter Maustaste, anschließend Auswahl des Menüs "Löschen".
 | Shortcut: | Strg+Entf
Beschreibung | Die selektierten Trenddefinitionen werden gelöscht.


Extras

Das Menü Extras bietet folgende Sonderfunktionen:

Statistik | Zeigt in der Statuszeile die Anzahl der Definitionen an.
Report | Ermöglicht den Druck der projektierten Definitionen des Archivsystems.
Ansicht aktualisieren | Aktualisiert die Ansicht aus der Datenbank.
Optionen | Öffnet den Konfigurationsdialog des Editors.


Ansicht aktualisieren

Aufruf | Menü: | Extras—>Ansicht aktualisieren
 | Shortcut: | F5
Beschreibung | Die Anbindung des Editors an die Projektdatenbank wird aktualisiert. Dies ist besonders wichtig beim parallelen Arbeiten mit mehreren Editoren und beim Projektieren an mehreren Arbeitsplätzen. Werden in einem Editor Gruppen im VisiWin-Projektexplorer gelöscht, die auch in einem anderen Editor sichtbar sind, so muss der andere Editor per Hand aktualisiert werden.


Statistik

Aufruf | Menü: | Extras—>Statistik
Beschreibung | In der Statuszeile des Editors wird eine Übersicht über die Anzahl der in der Komponente angelegten Definitionen angezeigt.


Optionen

Aufruf | Menü: | Extras—>Optionen
Beschreibung | Ruft den Dialog zum Festlegen der Editoroptionen auf. (Siehe auch "Einrichten des Editors").


Report

Aufruf | Menü: | Extras—>Report
Beschreibung | Über den Menüpunkt "Report" besteht die Möglichkeit, die projektierten Definitionen des Archivsystems auszudrucken. Weitere Informationen über das erstellen eines Reportes befinden sich im Handbuch "Projektreport".


Definitionen des Archivsystems

Archiv

Trend


Archiv

Editorfunktionen Siehe auch Beispiel
Archive legen das Speicherverhalten von Trenddaten fest. Sie werden im Projektexplorer unter dem Zugriffsknoten "Archive" (Symbol [image]) dargestellt und bieten u.a. folgende Funktionalität:
  • Festlegung des Speichermediums (Festplatte, RAM).
  • Trigger für Abtastung, Speicherstart, -stop und -auslagerung.
  • Festlegung der Dateigröße und fortlaufender Dateinamen bei Auslagerungen.

Parameter der Archivdefinition

Name | Beschreibung
Abtastungsart | Bestimmt, durch welches Ereignis Prozessvariablenwerte archiviert werden.
Abtastzeit | Bestimmt bei entsprechender Einstellung der Abtastart, in welchem Zyklus die Prozessvariablenwerte archiviert werden.
Archivgröße | Bestimmt die Anzahl von Abtastungen zwischen den Auslagerungsereignissen.
Cachegrösse | Bestimmt wie viele Messwerte aufgenommen werden, bevor in die Datei geschrieben wird.
Dateimodus | Zugriffsart auf die Archivdatei
Dateiname | Name der Archivdatei
Dateipfad | Pfad, unter dem die Archivdateien abgelegt werden.
Dateitrigger | Ereignis für Auslagerung in eine neue Datei (z.B.: Triggervariable, Zeit, Datum, Formel, ...)
Dateiwechselereignis | Ereignis zum Anlegen einer neuen Archivdatei
Daten speichern | Speicherort der Daten.
Kommentar | Kommentar zum Archiv
Laufzeitname | Archivbezeichnung in der VWTrend-Steuerelement-Legende
Löschvariable | Binärvariable (Wert = 1: aktuelles Archiv wird gelöscht, Trigger wird automatisch zurückgesetzt)
maximale Anzahl Dateien | Begrenzung der entstehenden Archivdaten.
maximale Dateiengesamtgröße | Begrenzung der entstehenden Archivdaten.
Name | Archivname im Projektexplorer
Redundanzdatei anlegen | Bestimmt, ob Redundanzdateien erzeugt werden
Redundanzdateipfad | Pfad, unter dem die Redundanzdateien abgelegt werden.
Ringpuffergröße | maximale Anzahl von Datensätzen im Archiv
Start/Stoppvariable | Binärvariable (Wert = 0: Stop der Aufzeichnung, Wert = 1: Start der Aufzeichnung)
Triggervariable | Abtasttrigger (wird automatisch zurückgesetzt)
Typ | Auslagerungsverhalten, Sicherheitsoptionen
xAchse | Welche Variable wird als Triggerstempel benutzt.


Siehe auch Archive

VisiWin Studio


Trend

Editorfunktionen Siehe auch Beispiel
Trends werden im Tabelleneditor als in einem Archiv enthaltene Definitionen durch Tabellenzeilen repräsentiert. Die wesentlichste Funktion einer Trenddefinition ist die Festlegung einer Prozessvariablen, die aufgezeichnet werden soll. Ein Trend erfüllt jedoch zusätzlich noch folgende Funktionen:
  • Filtermöglichkeiten
  • Fehlerkorrekturen
  • Aufzeichnungsskalierung
  • Abspeicherung der gewünschten Darstellungsart

Die Parameter des Trends lassen sich in zwei Kategorien einordnen:

  • Aufzeichnungsparameter: Die vom Archivserver erfassten Daten werden vor dem Ablegen in das Archiv durch diese Parametereinstellungen manipuliert.
  • Anzeigeparameter: Die Anzeigeparameter ermöglichen die Manipulation der Darstellungsart, beeinflussen jedoch nicht die im Archiv gespeicherten Daten.

Im Folgenden werden die Parameter der Trenddefinition zur besseren Übersicht mit den folgenden Symbolen aufgeführt:

Aufzeichnungsparameter:
Anzeigeparameter:

Parameter des Trends

Name | Beschreibung | Parametertyp
Anzeige Maximum | Maximal anzuzeigender Wert im Steuerelement |
Anzeige Minimum | Minimal anzuzeigender Wert im Steuerelement |
Anzeigename | Sprachumschaltbarer Trendname im Steuerelement |
Ausgabeart | Art der Ausgabe im Steuerelement (Kurvenart) |
Ausgabe-konfiguration | Art der Ausgabe im Steuerelement (Kurven- und Toleranzbandfarben) |
Ersatzwert Fehler | Ersatzwert, wenn Aufzeichnungsstörung vorliegt |
Ersatzwert Maximum | Ersatzwert, wenn Aufzeichnungswert oberhalb des Maximums liegt (variabel oder konstant) |
Ersatzwert Minimum | Ersatzwert, wenn Aufzeichnungswert unterhalb des Minimums liegt (variabel oder konstant) |
Farbe oberes Toleranzband | Farbe der oberen Toleranzbandlinie im Steuerelement |
Farbe unteres Toleranzband | Farbe der unteren Toleranzbandlinie im Steuerelement |
Filter | Filtermethode vor der Aufzeichnung |
Filtertiefe | Einstellung für den Parameter "Filter" |
Hysterese | Aufzeichnungshysterese (Differenzwert, bei dem ein Variablenwert aufgezeichnet wird) |
Hysterese Modus | Hysterese-Modus, Größenfestlegung für Hysterese |
Kommentar | Kommentar zum Trend |
Kurvenfarbe | Kurvenfarbe im Steuerelement |
Kurvenstärke | Kurvenstärke in Pixeln im Steuerelement |
Maximal sichtbare Samples | Maximal sichtbare Messwerte im Steuerelement |
Maximum | Aufzeichnungs-Maximum (variabel oder konstant) |
Minimum | Aufzeichnungs-Minimum (variabel oder konstant) |
Name | Eindeutiger Bezeichner der Definition |
Oberes Toleranzband | Wert für das obere Toleranzband im Steuerelement |
Trendvariable | Name der Prozessvariablen, die aufgezeichnet werden soll |
Unteres Toleranzband | Wert für das untere Toleranzband im Steuerelement |


Siehe auch Trend

VisiWin Studio


Parameter der Definitionen im Archivsystem

Alle Parameter

Parameter in alphabetischer Reihenfolge


Alle Parameter

Alphabetische Liste aller Parameter der Definitionen im Achivsystem

Abtastungsart
Abtastzeit
Anzeige Maximum
Anzeige Minimum
Anzeigename
Archivgröße
Ausgabeart
Ausgabekonfiguration
Cachegrösse
Dateimodus
Dateiname
Dateipfad
Dateitrigger
Dateiwechselereignis
Daten speichern
Ersatzwert Fehler
Ersatzwert Maximum
Ersatzwert Minimum
Farbe oberes Toleranzband
Farbe unteres Toleranzband
Filter
Filtertiefe
Hysterese
Hysterese Modus
Kommentar
Kurvenfarbe
Kurvenstärke
Laufzeitname
Löschvariable
maximale Anzahl Dateien
maximale Dateiengesamtgröße
Maximal sichtbare Samples
Maximum
Minimum
Name
Oberes Toleranzband
Redundanzdatei anlegen
Redundanzdateipfad
Ringpuffergröße
Start-/Stoppvariable
Trendvariable
Triggervariable
Typ
Unteres Toleranzband
x-Achse


Parameter in alphabetischer Reihenfolge

VisiWin Studio


Abtastungsart

Parameter für | Archiv
Beschreibung | Bestimmt, wann Prozessvariablenwerte in das Archiv geschrieben werden.
Einstellungen | Abtastungsart | Wert | Beschreibung
 | synchron zum Prozesszyklus | 0 | Als Zeitbasis der Aufzeichnung wird der VWE-Zyklus benutzt. Der Parameter "Abtastzeit" gibt an, welches Vielfache vom VWE-Zyklus als Abtastzeit genutzt wird. Die Einstellung für den VWE-Zyklus befindet sich im Variablensystem.
 | asynchron (absolute Zeitbasis) | 1 | Die Zeitbasis der Aufzeichnung ist eine Millisekunde. Der Parameter "Abtastzeit" gibt an, wie viele Millisekunden pro Abtastung verstreichen sollen.
 | Änderung der X-Variable | 2 | Eine Aufzeichnung erfolgt, wenn sich der Wert der Prozessvariablen ändert, die im Parameter "X-Achse" festgelegt wurde.
 | Trigger | 3 | Eine Aufzeichnung erfolgt, wenn die im Parameter "Trigger" festgelegte Prozessvariable den Wert "1" annimmt.
 | eine ändern, alle speichern | 4 | Eine Aufzeichnung erfolgt, wenn eine der aufgezeichneten Variablen ihren Wert ändert.
 | nur manuelle Aufzeichnung | 6 | Die Aufzeichnung erfolgt über die Aufzeichnungsfunktionen dss VWCOMponents-Objekts "VWSManualTrendSamples".
Datenbankfeld | SampleMode
Datentyp | Zahl (Long)
Standardwert | 0


Abtastzeit

Parameter für | Archiv
Beschreibung | Der Parameter "Abtastzeit" hat in Abhängigkeit vom Wert des Parameters "Abtastungsart" verschiedene Funktionen:
Einstellungen in Abhängigkeit vom Parameter "Abtastungsart" | Abtastungsart | Funktion
 | synchron | Anzahl der VWE-Zyklen pro Aufzeichnung
 | asynchron | Anzahl von Millisekunden zwischen den Aufzeichnungen
 | alle anderen | keine Funktion
Datenbankfeld | ScanTime
Datentyp | Zahl (Long)
Standardwert | 0


Anzeige Maximum

Parameter für | Trend
Beschreibung | Maximal anzeigbarer Aufzeichnungswert im Steuerelement: legt den Wert fest, an dem der dargestellte Aufzeichnungswert nach oben aus dem Steuerelement herauswandern wird.
Datenbankfeld | VMax
Datentyp | Zahl (Double)
Standardwert | 100


Anzeige Minimum

Parameter für | Trend
Beschreibung | Minimal anzeigbarer Aufzeichnungswert im Steuerelement: legt den Wert fest, an dem der dargestellte Aufzeichnungswert nach unten aus dem Steuerelement herauswandern wird. Die "Anzeige Minimum" legt zusammen mit der "Anzeige Maximum" den Darstellungsbereich der Aufzeichnungswerte fest.
Datenbankfeld | VMin
Datentyp | Zahl (Double)
Standardwert | 0


Anzeigename

Parameter für | Trend
Beschreibung | Sprachumschaltbarer Name, der in der Legende des Steuerelementes als Kurvenbezeichnung eingetragen wird. Der Name wird in einem Indextext abgelegt. Er kann im Indextexteditor in jede Projektsprache übersetzt werden.
Datenbankfeld | TextID (als Bezug auf einen Indextext)
Datentyp | String
Standardwert | 0
max. Länge | 255


Archivgrösse

Parameter für | Archiv
Beschreibung | Legt die Anzahl der Abtastungen fest, nach dem die Archivdatei ausgelagert wird. Wird das Archiv als Folgearchiv definiert (Parameter "Typ"), hat die Archivgröße nur eine Funktion, wenn der Parameter "Dateiwechselereignis" auf "Datensatzanzahl erreicht" eingestellt ist.
 | Die Anzahl der Abtastungen ist nicht identisch mit der Anzahl der Datensätze in der Archivdatei. Die Archivdatei beinhaltet nur geänderte Trenddaten. D. h. ändert sich der Wert der Trendvariable nicht, so wird bei einer erneuten Abtastung nur der Zeitstempel in der Archivdatei geändert.
Datenbankfeld | MaxSamples
Datentyp | Zahl (Long)
Standardwert | 0


Ausgabeart

Parameter für | Trend
Beschreibung | Bestimmt, ob und wie die Aufzeichnungswerte im Steuerelement miteinander verbunden werden sollen. Diese Funktion ist in dieser Version noch nicht implementiert.
Einstellungen | Ausgabeart | Wert | Beschreibung
 | Geraden- Interpolation | 0 | Die Aufzeichnungswerte werden durch Geraden verbunden.
 | Treppen-Interpolation | 1 | Der letzte Aufzeichnungswert wird bis zum aktuellen Messwert als Zwischenwert angenommen.
 | Spline- Interpolation | 2 | Die Messwerte werden durch Kurven einer kubischen Spline-Interpolation verbunden.
 | Punkte | 3 | Die Aufzeichnungswerte werden als Punkte dargestellt. Der Durchmesser eines dargestellten Messpunktes ist durch die Linienstärke (siehe Parameter Kurvenstärke) einstellbar.
 | Balken | 4 | Die Aufzeichnungswerte werden als Balkendiagramm dargestellt.
Datenbankfeld | VDrawMode
Datentyp | Zahl (Long)
Standardwert | 0


Ausgabekonfiguration

Parameter für | Trend
Beschreibung | Bestimmt, ob die Toleranzbänder angezeigt werden sollen und das Verhalten der Messkurve in Zusammenhang mit den Toleranzbändern.
Einstellungen | Ausgabeart | Wert | Beschreibung
 | Kurvenfarbe außerhalb der Toleranz wie Toleranzband | 1 | Wenn der Messwert den Bereich zwischen dem oberen und unteren Toleranzband verlässt, wird die Kurve in der Farbe des entsprechenden Toleranzbandes gefärbt.
 | Toleranzband als Linie | 2 | Oberes und unteres Toleranzband werden angezeigt.
 | Beides | 3 | Oberes und unteres Toleranzband werden angezeigt. Zusätzlich wird die Kurve in der Farbe des entsprechenden Toleranzbandes gefärbt, wenn der Messwert den Bereich zwischen dem oberen und unteren Toleranzband verlässt.
Datenbankfeld | VConfig
Datentyp | Zahl (Long)
Standardwert | 0


Cachegrösse

Parameter für | Archiv
Beschreibung | Bestimmt, wie viele Messwerte gepuffert werden, bevor in die Archivdatei geschrieben wird. Das Einrichten eines Caches für die zu speichernden Messwerte reduziert die Anzahl der Zugriffe auf die Archivdatei. Dadurch wird die Systemauslastung reduziert. Wird die Cachegrösse auf "0" (Vorgabewert) belassen, wird jeder aufgenommene Messwert direkt in die Archivdatei geschrieben. Die Eigenschaft wird vom Archivsystem ignoriert, wenn der Archivtyp auf "RAM" (siehe auf Parameter "Typ") eingestellt ist.
Datenbankfeld | CacheSize
Datentyp | Zahl (Long)
Standardwert | 0


Dateimodus

Parameter für | Archiv
Beschreibung | Der "Dateimodus" legt fest, wie die Daten in das Archiv geschrieben werden.
 | Wert | Beschreibung
 | Schnell | Die Archivdatei wird ab dem ersten Zugriff geöffnet gehalten, bis ein Ereignis zum Auslagern (siehe auch Parameter "Dateitrigger") auftritt. Die Arbeitsgeschwindigkeit des Archiv-Servers wird dadurch erhöht.
 | Sicher | Die Archivdatei wird nach jedem Zugriff geschlossen. Die Ausführungsgeschwindigkeit ist langsamer, die Datensicherheit ist bei einem Absturz des Systems jedoch höher.
Datenbankfeld | Type (Bit 4)
Datentyp | Zahl (Long)
Standardwert | 0


Dateiname

Parameter für | Archiv
Beschreibung Legt den Namen der Datei fest, unter der der Archivinhalt gespeichert werden soll.

Die Eingabemöglichkeiten für den "Dateinamen" gleichen denen eines sprachbezogenen Textes im Indextexteditor: Im Dateinamen können Prozessvariablenwerte dynamisch einbezogen werden. Der entsprechende Hilfsdialog zum Editieren der dynamisch einzubindenden Prozessvariablenwerte wird über die Schaltfläche [image] geöffnet.

Beispiel:

Der eingebundene dynamische Prozessvariablenwert wird zur Laufzeit mit den angegebenen Formatzeichen aufgelöst. Ist der Wert der Prozessvariablen "w0" zum Zeitpunkt des Abspeicherns z.B. 100, so wird die Archivdatei unter dem Namen Archiv100 abgespeichert.

Der Pfad, unter dem die Datei angelegt wird, wird durch den Parameter "Dateipfad" festgelegt.
Datenbankfeld | FileName, ParamNames
Datentyp | Text
Standardwert ""
max. Länge | 255


Dateipfad

Parameter für | Archiv
Beschreibung | Legt den Pfad fest, unter dem die Archivdatei gespeichert werden soll. Die Pfadangabe kann sowohl absolut (z.B.: C:\VisiWinStudio\Projekte\MyProject) als auch relativ zum Projektverzeichnis angegeben werden. Die relative Pfadangabe beginnt durch das Schlüsselwort "<ProjectDir> (z.B.: "<ProjectDir>\Archive" greift auf das Unterverzeichnis "Archive" des Projektverzeichnisses zu. Der Dateiname wird im Parameter "Dateiname" festgelegt. Das Verzeichnis wird zur Laufzeit vom Archivserver automatisch angelegt, falls es nicht vorhanden ist.
Datenbankfeld | FilePath
Datentyp | Text
Standardwert | "<ProjectDir>"
max. Länge | 255


Dateitrigger

Parameter für | Archiv
Beschreibung | Legt den Namen der Variable fest, bei deren Wertänderung auf "1" eine neue Auslagerungsdatei erstellt wird. Im Editor wird über die Schaltfläche [image] ein Dialog zur Auswahl einer Prozessvariablen geöffnet. Der Dateitrigger hat nur eine Bedeutung, wenn der Parameter "Dateiwechselereignis" auf "Triggervariable gesetzt" eingestellt wird. Nach dem Auslagern der Datei wird die Triggervariable automatisch zurückgesetzt.
Datenbankfeld | NewFile
Datentyp | Text
Standardwert | ""
max. Länge | 255


Dateiwechselereignis

Parameter für | Archiv
Beschreibung | Legt das Ereignis fest, welches zum Anlegen einer neuen Archivdatei führt.
Eingaben | Dateiwechselereignis | Beschreibung
 | Triggervariable gesetzt | Es wird eine neue Auslagerungsdatei angelegt, wenn die im Parameter "Dateitrigger" angegebene Variable den Wert "1" annimmt.
 | Datensatzanzahl erreicht | Es wird eine neue Auslagerungsdatei angelegt, wenn die Anzahl der im aktuellen Archiv gespeicherten Datensätze die im Parameter "Archivgröße" angegebene Zahl überschreitet.
 | Jahreswechsel | Es wird eine neue Auslagerungsdatei bei jedem Jahreswechsel der Systemzeit angelegt.
 | Monatswechsel | Es wird eine neue Auslagerungsdatei bei jedem Monatswechsel der Systemzeit angelegt.
 | Wochenwechsel | Es wird eine neue Auslagerungsdatei bei jedem Wochenwechsel der Systemzeit angelegt.
 | Tageswechsel | Es wird eine neue Auslagerungsdatei bei jedem Tageswechsel der Systemzeit angelegt.
 | Stundenwechsel | Es wird eine neue Auslagerungsdatei bei jedem Stundenwechsel der Systemzeit angelegt.
 | Minutenwechsel | Es wird eine neue Auslagerungsdatei bei jedem Minutenwechsel der Systemzeit angelegt.
 | Sekundenwechsel | Es wird eine neue Auslagerungsdatei bei jedem Sekundenwechsel der Systemzeit angelegt.
 | Niemals | Die Archivdatei kann beliebig wachsen.
Datenbankfeld | NewFile
Datentyp | Text
Standardwert | ""
max. Länge | 255


Daten speichern

Parameter für | Archiv
Beschreibung | Der Parameter "Daten speichern" bestimmt, ob die Archivdaten persistent gespeichert werden sollen.
 | Einstellung | Beschreibung
 | auf Festplatte | Die Archivdatei wird auf Festplatte geschrieben.
 | Im Arbeits- speicher | Die Archivdatei wird im Arbeitsspeicher des Rechners gehalten. Sie ist nur bis zum Ende der laufenden Applikation existent.
Datenbankfeld | Type
Datentyp | Zahl (Long)
Standardwert | 0


Ersatzwert Fehler

Parameter für | Trend
Beschreibung | Für den Fall, dass eine Verbindungsstörung zwischen der SPS und dem PC auftritt, der zu archivierende Prozessvariablenwert also nicht mehr zu ermitteln ist, kann ein Ersatzwert festgelegt werden, der anstelle des wahren Wertes aufgezeichnet wird. Der Parameter "Ersatzwert Fehler" akzeptiert folgende Eingaben:
Eingaben | Typ | Beschreibung
 | Double | Eine Konstante (Nachkommastellen von Vorkommastellen durch einen "." trennen, z.B.: 1.234)
 | String | Der Name einer anderen Prozessvariablen, deren aktueller Wert anstelle des eigentlichen Wertes archiviert wird. Im Editor wird über die Schaltfläche [image] ein Dialog zur Auswahl einer Prozessvariablen geöffnet.
Datenbankfeld | ErrorValue
Datentyp | String
Standardwert | ""
max. Länge | 255


Ersatzwert Maximum

Parameter für | Trend
Beschreibung | Ein Ersatzwert, wenn der Aufzeichnungswert den im Parameter "Maximum" festgelegten Wert übersteigt. Der Parameter "Ersatzwert Maximum" akzeptiert folgende Eingaben:
Eingaben | Typ | Beschreibung
 | Double | Eine Konstante (Nachkommastellen von Vorkommastellen durch einen "." trennen, z.B.: 1.234)
 | String | Der Name einer anderen Prozessvariablen, deren aktueller Wert anstelle des eigentlichen Wertes archiviert wird. Im Editor wird über die Schaltfläche [image] ein Dialog zur Auswahl einer Prozessvariablen geöffnet.
Datenbankfeld | SurrogateMax
Datentyp | Text
Standardwert | ""
max. Länge | 255


Ersatzwert Minimum

Parameter für | Trend
Beschreibung | Ein Ersatzwert, wenn der Aufzeichnungswert den im Parameter "Minimum" festgelegten Wert unterschreitet. Der Parameter "Ersatzwert Minimum" akzeptiert folgende Eingaben:
Eingaben | Typ | Beschreibung
 | Double | Eine Konstante (Nachkommastellen von Vorkommastellen durch einen "." trennen, z.B.: 1.234)
 | String | Der Name einer anderen Prozessvariablen, deren aktueller Wert anstelle des eigentlichen Wertes archiviert wird. Im Editor wird über die Schaltfläche [image] ein Dialog zur Auswahl einer Prozessvariablen geöffnet.
Datenbankfeld | SurrogateMin
Datentyp | Text
Standardwert |
max. Länge | 255


Farbe oberes Toleranzband

Parameter für | Trend
Beschreibung | Bestimmt die Farbe des oberen Toleranzbandes im Steuerelement. Toleranzbänder werden im Steuerelement als waagerechte Linien dargestellt. Sie sollen die Über-/Unterschreitung von Grenzen markieren. Die Toleranzbänder werden über den Parameter "Ausgabekonfiguration" sichtbar geschaltet. Im Editor wird über die Schaltfläche [image] ein Dialog zur Auswahl einer Farbe geöffnet.
Datenbankfeld | VUpperColor
Datentyp | Zahl (Long)
Standardwert | 0


Farbe unteres Toleranzband

Parameter für | Trend
Beschreibung | Bestimmt die Farbe des unteren Toleranzbandes im Steuerelement. Toleranzbänder werden im Steuerelement als waagerechte Linien dargestellt. Sie sollen die Über-/Unterschreitung von Grenzen markieren. Die Toleranzbänder werden über den Parameter "Ausgabekonfiguration" sichtbar geschaltet. Im Editor wird über die Schaltfläche [image] ein Dialog zur Auswahl einer Farbe geöffnet.
Datenbankfeld | VLowerColor
Datentyp | Zahl (Long)
Standardwert | 0


Filter

Parameter für | Trend
Beschreibung | Aufzeichnungs-Filter: Bevor ein Prozessvariablenwert archiviert wird, kann er mit Hilfe der Parameter "Filter" und "Filtertiefe" gefiltert werden. Der Parameter "Filtertiefe" gibt dabei die Anzahl der im Filter verarbeiteten Meßwerte an. Der aktuelle Meßwert wird zusammen mit der <Filtertiefe> Anzahl der zuletzt gemessenen Werte in der Filteroperation verarbeitet.
Einstellungen | Filter | Wert | Beschreibung
 | kein Filter | 0 | Es wird kein Aufzeichnungsfilter angewendet.
 | Mittelwert | 1 | Wird die Filtertiefe auf "0" gestellt, so wird keine Mittelwertbildung vorgenommen
 | Mittelung | 2 | Wird die Filtertiefe auf "0" gestellt, so bezieht sich die Mittelung auf alle Messwerte seit dem Start der Aufzeichnung.
 | Maximum | 3 | Der maximale Wert der letzten <Filtertiefe> gemessenen Werte wird archiviert.
 | Minimum | 4 | Der minimale Wert der letzten <Filtertiefe> gemessenen Werte wird archiviert.
Datenbankfeld | Filter
Datentyp | Zahl (Long)
Standardwert | 4


Filtertiefe

Parameter für | Trend
Beschreibung | Gibt die Anzahl der Messwerte für Filteroperationen (siehe Parameter "Filter") an.
Datenbankfeld | FilterDepth
Datentyp | Zahl (Long)
Standardwert | 0


Hysterese

Parameter für | Trend
Beschreibung | Die Festlegung einer Hysterese im Trend kann zur Datenkompression genutzt werden. Prozessvariablenwerte werden nur dann in das Archiv geschrieben, wenn sie sich um einen im "Hysterese" Parameter festgelegten Wert gegenüber dem zuletzt gespeicherten Wert ändern. Der Hysteresewert kann absolut oder auch relativ angegeben werden (Siehe auch: Parameter "Hysterese Modus"). Der Parameter "Hysterese" akzeptiert folgende Eingaben:
Eingaben | Typ | Beschreibung
 | Double | Eine Konstante (Nachkommastellen von Vorkommastellen durch einen "." trennen, z.B.: 1.234)
 | String | Der Name einer anderen Prozessvariablen, deren aktueller Wert als Hysterese genutzt wird. Im Editor wird über die Schaltfläche [image] ein Dialog zur Auswahl einer Prozessvariablen geöffnet.
Datenbankfeld | Hysteresis
Datentyp | Text
Standardwert | ""
max. Länge | 255


Hysterese Modus

Parameter für | Trend
Beschreibung | Der Hysterese-Modus bestimmt, wie der Wert des Parameters "Hysterese" interpretiert wird.
Eingaben | Hysterese Modus | Wert | Beschreibung
 | absolut | 0 | Der Wert des Parameters "Hysterese" wird als Aufzeichnungshysterese benutzt.
 | In Promille von 'Maximum– Minimum' | 1 | Der Wert des Parameters "Hysterese" wird als 1/1000 von der Differenz der Parameter "Maximum" und "Minimum" interpretiert.
 | In Promille vom Aufzeichnungs- wert | 2 | Der Wert des Parameters "Hysterese" wird als 1/1000 vom zuletzt aufgezeichneten Wert interpretiert.
Datenbankfeld | HysteresisMode
Datentyp | Zahl (Long)
Standardwert | 0


Kommentar

Parameter für | Archiv, Trend
Beschreibung | Zeile für einen beliebigen Text: Ein kurzer Hinweis auf die Funktionalität der jeweiligen Definition erhöht die Übersicht und erleichtert die Orientierung für den Entwickler.
Datenbankfeld | Comment
Datentyp | Text
Standardwert | ""
max. Länge | 255


Kurvenfarbe

Parameter für | Trend
Beschreibung | Bestimmt die Farbe der anzuzeigenden Trendkurve im Steuerelement. Im Editor wird über die Schaltfläche [image] ein Dialog zur Auswahl einer Farbe geöffnet.
Datenbankfeld | VLineColor
Datentyp | Zahl (Long)
Standardwert | 0


Kurvenstärke

Parameter für | Trend
Beschreibung | Bestimmt die Stärke der Kurve im Steuerelement. Die Einheit dabei ist "Pixel".
Datenbankfeld | VLineWidth
Datentyp | Zahl (Long)
Standardwert | 0


Laufzeitname

Parameter für | Archiv
Beschreibung | Sprachumschaltbarer Name, der in der Legende des Steuerelementes als Archivbezeichnung eingetragen wird. Der Name wird in einem Indextext abgelegt. Er kann im Indextexteditor in jede Projektsprache übersetzt werden.
Datenbankfeld | TextID (als Bezug auf einen Indextext)
Datentyp | Zahl (Long)
Standardwert | 0


Löschvariable

Parameter für | Archiv
Beschreibung | Name einer Prozessvariablen (Digitalvariablen). Durch das Setzen des Variablenwertes auf "1" wird der Inhalt der Archivdatei gelöscht. Nach dem Löschen des Archivinhaltes wird der Wert der Löschvariablen automatisch auf "0" zurückgesetzt. Im Editor wird über die Schaltfläche [image] ein Dialog zur Auswahl einer Prozessvariablen geöffnet.
Datenbankfeld | Reset
Datentyp | Text
Standardwert | ""
max. Länge | 255


maximale Anzahl Dateien

Parameter für | Archiv
Beschreibung | Der Parameter "maximale Anzahl Dateien" legt fest, wieviele Archivdateien durch die Archivdefinition maximal auf der Festplatte angelegt werden können. Wird die hier angegebene Anzahl überschritten, werden die ältesten Archivdateien gelöscht. Dies dient dazu, die Festplatte vor einem Überlauf zu schützen.
 | Der Parameter ist nur aktiv, wenn der Parameter "Typ" auf "Folgearchiv" und der Parameter "Daten speichern" auf "auf Festplatte" eingestellt sind. Eine andere Methode zur Begrenzung der Archivdaten auf der Festplatte wird über den Parameter "maximale Dateiengesamtgröße" ermöglicht.
Datenbankfeld | MaxFiles
Datentyp | Long
Standardwert | 0


maximale Dateiengesamtgröße

Parameter für | Archiv
Beschreibung | Der Parameter "maximale Dateiengesamtgröße" legt fest, welchen Speicherplatz die Archivdateien der Archivdefinition maximal einnehmen dürfen. Wird die hier (in Kilobyte) angegebene Größe überschritten, werden die ältesten Archivdateien gelöscht. Dies dient dazu, die Festplatte vor einem Überlauf zu schützen.
Der Parameter ist nur aktiv, wenn der Parameter "Typ" auf "Folgearchiv" und der Parameter "Daten speichern" auf "auf Festplatte" eingestellt sind.

Wird der Parameter "Dateimodus" auf "schnell" gestellt, kann es zu einer Überschreitung der hier vorgegebenen Größe kommen. Der Größenvergleich wird erst ausgeführt, nachdem die im Cache gehaltenen Archivdaten in die Datei geschrieben wurden. Ist im Cache liegende Datenmenge sehr groß, führt dies unter Umständen dazu, dass mehrere ältere Dateien gelöscht werden müssen, um die maximale Dateiengesamtgröße einzuhalten.

Eine andere Methode zur Begrenzung der Archivdaten auf der Festplatte wird über den Parameter "maximale Anzahl Dateien" ermöglicht.
Datenbankfeld | MaxFiles
Datentyp | Long
Standardwert | 0


Maximal sichtbare Samples

Parameter für | Trend
Beschreibung | Legt die Anzahl der maximal sichtbaren Messwerte im Steuerelement fest und bemisst damit die X-Achse.
Datenbankfeld | VMaxSamples
Datentyp | Zahl (Long)
Standardwert | 0


Maximum

Parameter für | Trend
Beschreibung | Legt die obere Grenze fest, die der Prozessvariablenwert annehmen kann, ohne im Archiv vom "Ersatzwert Maximum" überschrieben zu werden. Der Parameter "Maximum" akzeptiert folgende Eingaben:
Eingaben | Typ | Beschreibung
 | Double | Eine Konstante (Nachkommastellen von Vorkommastellen durch einen "." trennen, z.B.: 1.234)
 | String | Der Name einer anderen Prozessvariablen, deren aktueller Wert als Maximum-Wert genutzt wird. Im Editor wird über die Schaltfläche [image] ein Dialog zur Auswahl einer Prozessvariablen geöffnet.
 | keine Eingabe | Es wird keine Überprüfung durchgeführt.
Datenbankfeld | Maximum
Datentyp | Text
Standardwert | ""
max. Länge | 255


Minimum

Parameter für | Trend
Beschreibung | Legt die Untergrenze fest, die der Prozessvariablenwert annehmen kann, ohne im Archiv vom "Ersatzwert Minimum" überschrieben zu werden. Der Parameter "Minimum" akzeptiert folgende Eingaben:
Eingaben | Typ | Beschreibung
 | Double | Eine Konstante (Nachkommastellen von Vorkommastellen durch einen "." trennen, z.B.: 1.234)
 | String | Der Name einer anderen Prozessvariablen, deren aktueller Wert als Minimum-Wert genutzt wird. Im Editor wird über die Schaltfläche [image] ein Dialog zur Auswahl einer Prozessvariablen geöffnet.
 | keine Eingabe | Es wird keine Überprüfung durchgeführt.
Datenbankfeld | Minimum
Datentyp | Text
Standardwert | ""
max. Länge | 255


Name

Parameter für | Archiv, Trend
Beschreibung | Name der VisiWinStudio-Definition. Der Name unterliegt den Konventionen der eindeutigen Namensvergabe.
Datenbankfeld | Name
Datentyp | Text
Standardwert | ""
max. Länge | 50


Oberes Toleranzband

Parameter für | Trend
Beschreibung | Bestimmt die y-Position der Linie, die im Steuerelement das obere Toleranzband repräsentiert. Der Wert für das obere Toleranzband wird auf den archivierten Wert des Trends bezogen.
Datenbankfeld | VUpper
Datentyp | Zahl (Double)
Standardwert | 0


Redundanzdatei anlegen

Parameter für | Archiv
Beschreibung Die Option "Redundanzdatei anlegen" erhöht die Datensicherheit. Jede Archivdatei wird in zwei Dateien gespeichert:
  • Als Archivdatei unter dem "Dateinamen" in den "Dateipfad".
  • Als Redundanzdatei mit dem gleichen Namen, jedoch unter dem "Redundanzdateipfad".

Dies erhöht die Datensicherheit: Die Dateien werden nacheinander geöffnet und beschrieben, sodass niemals beide gleichzeitig geöffnet sind. Im Fall eines Rechnerabsturzes (z.B. durch Stromausfall) wird dadurch sichergestellt, dass die Daten zumindest in einer Datei erhalten bleiben. Nach einem Absturz versucht der Archivserver zuerst die Originaldatei zu öffnen. Ist die Datei defekt, wird automatisch die Redundanzdatei geöffnet. Beim nächsten schreibenden Zugriff wird die Originaldatei dann mit den Daten der Redundanzdatei restauriert.
Das Anlegen einer Redundanzdatei kann durch den doppelten Dateizugriff die Geschwindigkeit des Systems reduzieren.
Datenbankfeld | Type
Datentyp | Zahl (Long)
Standardwert | 0


Redundanzdateipfad

Parameter für | Archiv
Beschreibung | Legt den Pfad fest, unter dem die Redundanzdatei eines Archives gespeichert werden soll. Die Pfadangabe kann sowohl absolut (z.B.: C:\VisiWinStudio\Projekte\MyProject\Redundanz) als auch relativ zum Projektverzeichnis angegeben werden. Die relative Pfadangabe beginnt durch das Schlüsselwort "<ProjectDir> (z.B.: "<ProjectDir>\Redundanz" greift auf das Unterverzeichnis "Redundanz" des Projektverzeichnisses zu. Der Dateiname der Redundanzdatei wird im Parameter "Dateiname" festgelegt.
Datenbankfeld | RedundancyPath
Datentyp | Text
Standardwert | "<ProjectDir>"
max. Länge | 255


Ringpuffergröße

Parameter für | Archiv
Beschreibung | Legt die maximale Anzahl von Datensätzen im Archiv fest.
 | Der Zeitraum, in dem alte Daten überschrieben werden, ist nicht allein abhängig von der hier eingestellten Anzahl von Abtastwerten. Ein neuer Abtastwert wird nur in das Archiv geschrieben, wenn sich der Wert der aufgezeichneten Trendvariable ändert. Ein unveränderter Trendvariablenwert bewirkt bei einer erneuten Abtastung nur die Änderung des Zeitstempels des zuletzt eingetragenen Wertes im Archiv.
 | Dieser Parameter ist nur aktiv, wenn der Parameter "Typ" entsprechend eingestellt wurde. Eine Größenangabe für Folgearchive ist im Parameter "Archivgröße" einstellbar.
Datenbankfeld | MaxSamples
Datentyp | Zahl (Long)
Standardwert | 0


Start/Stoppvariable

Parameter für | Archiv
Beschreibung | Name einer Prozessvariablen, durch deren Wertänderung die Aufzeichnung im Archiv gestartet oder gestoppt wird. Im Editor wird über die Schaltfläche [image] ein Dialog zur Auswahl einer Prozessvariablen geöffnet.
Prozessvariablenwert | 0 | Die Aufzeichnung wird gestoppt.
 | 1 | Die Aufzeichnung wird gestartet.
Datenbankfeld | StartStop
Datentyp | Text
Standardwert | ""
max. Länge | 255


Trendvariable

Parameter für | Trend
Beschreibung | Bestimmt den Namen der Prozessvariablen, deren Werte im Archiv aufgezeichnet werden sollen. Im Editor wird über die Schaltfläche [image] ein Dialog zur Auswahl einer Prozessvariablen geöffnet.
Datenbankfeld | TrendVar
Datentyp | Text
Standardwert | ""
max. Länge | 255


Triggervariable

Parameter für | Archiv
Beschreibung | Der Parameter "Triggervariable" gibt den Namen der Prozessvariable an, bei deren Wertänderung auf "1" eine Abtastung der Trendvariablen erfolgen soll. Die "Triggervariable" hat nur eine Funktion, wenn der Wert des Parameters "Abtastungsart" auf "Trigger" gestellt ist.
Datenbankfeld | Trigger
Datentyp | Text
Standardwert | ""
max. Länge | 255


Typ

Parameter für | Archiv
Beschreibung | Der Parameter "Typ" bestimmt, ob das Archiv als Ringpuffer oder als Folgearchiv funktioniert:
 | Einstellungen | Beschreibung
 | Ringpuffer | Die maximale Anzahl von Abtastwerten im Archiv wird durch den Parameter "Ringpuffergröße" festgelegt. Dazu wird ein fester Speicherbereich reserviert. Ist der Speicherbereich erstmalig mit Aufzeichnungs- werten gefüllt, wird die Aufzeichnung am Beginn des Speicherbereiches fortgesetzt. Damit werden die "ältesten" Aufzeichnungswerte überschrieben.
 | Folgearchiv | Die Archivdatei kann sich beliebig vergrößern. Eine Auslagerung erfolgt wenn: a) Das Archiv die festgelegte Größe ("Archivgröße" > 0 ) überschreitet oder b) Ein Auslagerungsereignis auftritt (Siehe Parameter "Dateiwechselereignis")
Datenbankfeld | Type
Datentyp | Zahl (Long)
Standardwert | 0


Unteres Toleranzband

Parameter für | Trend
Beschreibung | Bestimmt die y-Position der Linie, die im Steuerelement das untere Toleranzband repräsentiert. Der Wert für das untere Toleranzband wird auf den archivierten Wertebereich des Trends bezogen.
Datenbankfeld | VLower
Datentyp | Zahl (Double)
Standardwert | 0


xAchse

Parameter für | Archiv
Beschreibung | Der Parameter "X-Achse" gibt den Namen der Prozessvariable an, bei deren Wertänderung eine Abtastung aller Trendvariablen erfolgen soll. Der Parameter "X-Achse" hat nur eine Funktion, wenn der Parameter "Abtastungsart" auf "Änderung der X-Variable" eingestellt wird.
Datenbankfeld | XVar
Datentyp | Text
Standardwert | ""
max. Länge | 255


Allgemeine Editierregeln

Selektieren von Definitionen

Feldinhalte ändern

Einrichten des Editors

Eindeutige Namensvergabe

Maus und Tastaturreferenz


Selektieren von Definitionen

Bestimmte Funktionen der VisiWinStudio Editoren stehen nur für selektierte (markierte) Definitionen zur Verfügung (z.B. das Löschen einer Definition).

Eine oder mehrere Definitionen können sowohl mit der Maus als auch mit der Tastatur selektiert werden.

Selektieren mit der Maus

Einfache Selektion:

Eine Definition kann mit der linken Maustaste über das Selektierzeichen ( [image] am linken Rand der Tabelle) markiert werden.

Selektion mehrerer Definitionen:

Bei heruntergehaltener Strg-Taste können weitere Definitionen durch einen Mausklick auf das Selektierzeichen markiert werden.
Selektion eines zusammenhängenden Bereiches

Ein zusammenhängender Bereich von Definitionen wird in zwei Schritten selektiert.

1. Selektieren der Definition, bei dem der Bereich beginnen soll (durch Mausklick auf das Selektierzeichen).

2. Bei gehaltener Umschalt-Taste die Definition selektieren, die das Ende des Bereiches markieren soll.

Selektieren mit der Tastatur

Durch die Tastaturkombinationen Umschalt + Pfeil runter/Pfeil hoch kann ein Bereich von Definitionen markiert werden.


Feldinhalte ändern

Die Editortabellen befinden sich standardmäßig im Navigationsmodul, d.h.: Beim Bewegen in den Editortabellen über die Cursortasten springt der Cursor von einem Feld zum nächsten. Beim Springen von einem Feld zum nächsten ist der gesamte Feldinhalt markiert. Nun folgende Eingaben überschreiben den gesamten Feldinhalt.

Um dies zu vermeiden (z.B.: es soll nur ein einzelnes Zeichen im Feld korrigiert werden), kann das Feld über die Taste F2 in den Editiermodus geschaltet werden. Im Editiermodus ist über die Cursor-links/-rechts-Tasten das Scrollen im Feldinhalt möglich. Der Feldeditiermodus wird automatisch beim Scrollen über die Begrenzungen des Feldinhaltes (Anfang und Ende des Feldtextes) verlassen. Er kann auch durch erneutes Betätigen der Taste F2 verlassen werden.


Einrichten des Editors

Über den Eintrag Extras-> Optionen im Editor-Hauptmenü wird ein Dialog geöffnet, der Editoreinstellungen zur Verfügung stellt.

Einrichten der Tabellen

Über den entsprechenden Karteireiter ist die zu formatierende Tabelle anzuwählen.

Die rechte Liste zeigt alle Tabellenspalten an, die zurzeit in der Tabelle angezeigt werden. In der linken Liste werden alle Spalten aufgeführt, die zur Verfügung stehen, jedoch nicht angezeigt werden. Über die vier Schaltflächen zwischen den beiden Listen können folgende Funktionen ausgeführt werden:

Fügt die in der "vorhanden"-Liste markierte Spalte in die "angezeigt"-Liste ein. Die Spalte wird in der Tabelle nach dem Schließen des Dialoges sichtbar.
Fügt die in der "angezeigt"-Liste markierte Spalte in die "vohanden"-Liste ein. Die Spalte wird in der Tabelle nach dem Schließen des Dialoges ausgeblendet.
Schiebt die in der "angezeigt" Liste markierte Spalte um einen Eintrag nach oben. Die Reihenfolge der Einträge in der "angezeigt" Liste (von oben nach unten) gibt die Anzeigereihenfolge der Spalten in der Tabelle (von links nach rechts) an.
Schiebt die in der "angezeigt" Liste markierte Spalte um einen Eintrag nach unten.

Wahl der Schriftart im Editor

Bestimmt die Schriftart der Editortabellenfelder und Spaltenüberschriften.

Ausnahme: Im Indextexteditor wird für jede Sprachspalte eine eigene Schriftart festgelegt.


Eindeutige Namensvergabe

Der Zugriff auf die VisiWin-Definitionen erfolgt über eine Namens-Pfadangabe. Dieser Zugriffspfad muss eindeutig sein, d.h. über diesen Zugriffspfad darf nur genau eine Definition angesprochen werden können. Der Pfad ergibt sich aus der Gruppenhierarchie im VisiWin-Projektexplorer (Die Namen der einzelnen Gruppen vom Hauptknoten bis hinunter zu der Gruppe, in der sich die Definition befindet). Der Name ist der Parameter "Name" der Definition. Aus dieser Festlegung ergeben sich zwei Regeln:

  • Der Parameter "Name" einer Definition muss innerhalb einer Gruppe eindeutig sein.
  • In einer anderen Gruppe darf derselbe Name noch einmal benutzt werden.

Analogie: Der Name einer Definition ist vergleichbar mit dem Namen einer Datei in einem Verzeichnis. In jedem Verzeichnis darf ein Dateiname nur einmal verwendet werden. Jedoch darf eine gleichnamige Datei in einem anderen Verzeichnis liegen.


Maus und Tastaturreferenz

Im Folgenden eine Referenz aller editorspezifischen Tastaturkürzel und Mausbedienungen.

Tabellenfunktionen

Verändern einer Spaltenbreite | Ziehen des Spaltentrenners am rechten Rand der betreffenden Tabellenspalte im Überschriftenbereich mit der Maus.
Anpassen der Spaltenbreite, so dass alle Textfelder voll sichtbar sind. | Doppelklick auf den rechten Spaltentrenner einer Tabellenspalte.
Verändern der Zeilenhöhe | Ziehen des Zeilentrenners
Einsteigen in den Feldeditiermodus | F2
Auswahl eines Menüpunktes über die Tastatur | ALT+ unterstrichener Buchstabe im gewünschten Menü
Schließen des Tabelleneditors | ALT+F4
Wechsel zum Projektexplorer | Alt+F6

Definitionenfunktionen

Definition hinzufügen | F8
Definition editieren | F9
selektierte(s) Definition(en)/ Inhalt eines Feldes löschen | Strg+Entf

ProjektExplorer-Funktionen

expandieren eines Zweiges | Pfeil rechts (wenn der selektierte Knoten mit einem "+" Zeichen versehen ist.
zusammenklappen eines Zweiges | Pfeil links (wenn der selektierte Knoten mit einem "-" Zeichen versehen ist.
Zum nächsten Knoten scrollen | Pfeil nach unten.
Zum vorherigen Knoten scrollen | Pfeil nach oben.
Öffnen eines Tabelleneditors | Doppelklick auf einen nicht expandierten Knoten der entsprechenden Komponente.
Wechsel zu einem Tabelleneditor | Alt+F6


Inhalt

Einführung in das VisiWinStudio Archivsystem

Projektierung

Definitionen des Archivsystems

Parameter der Definitionen im Archivsystem

Allgemeine Editierregeln