Einleitung Kommunikationstreiber

Die vorliegende Dokumentation beschreibt die für diesen Kommunikationstreiber typischen Merkmale und Einstellungen. Sie soll Ihnen helfen den Kommunikationstreiber mit den ihn spezifischen Einstellungen zu konfigurieren und zu optimieren.

Wollen Sie Information zur Installation und zur Bedienung der Oberfläche des Kommunikationstreibers und des Konfigurators, so schauen Sie bitte in die allgemeine Hilfe [VWSTreiber.chm]. Dort finden die auch Informationen zu internen Abläufen im Kommunikationstreiber und zwischen dem VWEKernel, der die Datenbank bearbeitet und dem Kommunikationstreiber .

Und noch einmal folgender wichtiger Hinweis:

Die Vergangenheit hat gezeigt, dass es gerade bei der Inbetriebnahme immer wieder zu Problemen verschiedenster Art gekommen ist. Besonders an der Schnittstelle zwische Soft- und Hardware kann es immer wieder zu unerwarteten Problemen kommen. Daher möchten wir an dieser Stelle noch einmal daraufhin weisen, dass es auf alle Fälle immer sinnvoll ist, die Kommunikation schon zu Begin eines Projektes zu testen, um nicht bei der Inbetriebnahme in unnötige Schwiegigkeiten zu kommen. Desweiteren ist zu beachten, dass die Kommunikation sich mit einer komplettenen "grossen" Datenbank anders verhält als mit einer Testdatenbank, die nur einige Objekte beinhaltet (siehe Optimierung im allgemeinen Hilfeteil).


Spezifisch

Beschreibt die für diesen Kommunikationstreiber spezifische Parameter. Diese Werte erhalten Sie in dem Konfigurationstool unter dem Treeeintrag: Spezifisch.


Zeitbasis 1

Stellen sie hier eine Zeitbasis in Millisekunden ein. Mit dieser Zeitbasis werden die Zufallsgeneratoren und das Lauflicht aus der "DUMMY" Struktur verändert.


Zeitbasis 2

Dieser Eintrag hat zur Zeit noch keine Auswirkung und dient als Reserveeintrag für künftige Anwendungen.


Zeitbasis 3

Stellen sie hier eine weitere Zeitbasis in Millisekunden ein. Es werden die Sägezahn- und die Sinusgeneratoren aus der "DUMMY" Adresse verändert.


Aufbau der Adresse

Der Aufbau des Adress-Strings unterliegt bei diesem Kommunikationstreiber keiner Restriktion und kann beliebig vergeben werden. Gleiche Strings sollten vermieden werden!

Für jede von Ihnen angelegte Adresse resierviert der Kommunikationstreiber endsprechenden Speicher. Dieser Speicher kann von der Applikation gelesen oder beschrieben werden.


Feste Adressen

Einige Address-String sind fest vorgegeben und werden vom Kommunikationstreiber speziell behandelt.


DUMMY

Diese Struktur hat ein Länge von 16 Worten und hat folgenden Aufbau:

Itemname (kann frei vergeben werden) | Datentyp | Beschreibung
Saege1 | WORD VT_UI2 | Sägezahn mit Werten von 0 bis 100 Steigung Steigung 1 auf Zeitbasis 3
Saege2 | WORD VT_UI2 | Sägezahn mit Werten von 0 bis 100 Steigung Steigung 2 auf Zeitbasis 3
Saege3 | WORD VT_UI2 | Sägezahn mit Werten von -100 bis 100 Steigung Steigung 4 auf Zeitbasis 3
Saege4 | WORD VT_UI2 | Sägezahn mit Werten von -100 bis 100 Steigung Steigung 3 auf Zeitbasis 3
Sin1 | Float VT_R4 | Sinus –100 bis 100 Steigung 2 Zeitbasis 3
Sin2 | Float VT_R4 | Sinus –100 bis 100 Steigung 5 Zeitbasis 3
Rand1 | WORD VT_UI2 | Zufallswert Zeitbasis 1
Rand2 | WORD VT_UI2 | Zufallswert Zeitbasis 1
Rand3 | WORD VT_UI2 | Zufallswert Zeitbasis 1
Rand4 | WORD VT_UI2 | Zufallswert Zeitbasis 1
LauflichtR | DWORD VT_UI4 | Lauflicht (1 Bit) geschiftet nach rechts Zeitbasis 1
LauflichtL | DWORD VT_UI4 | Lauflicht (1 Bit) geschiftet nach links Zeitbasis 1

Sie können die Werte aus dieser Struktur benutzen um "Leben" in Ihre Applikation zu bringen.


OCX

Diese Adresse wird von einer VisiWin Demo Applikation verwendet und sollte von Ihren Applikationen nicht verwendet werden.


TIM

Diese Adresse wird von einer VisiWin Demo Applikation verwendet und sollte von Ihren Applikationen nicht verwendet werden.


TUTORIUM

Diese Adresse wird von einer VisiWin Demo Applikation verwendet und sollte von Ihren Applikationen nicht verwendet werden.


Anzeige der Fehlermeldungen

Die Fehlermeldungen werden im Fenster des Kommunikationstreibers angezeigt. Zudem werden die Meldungen bei Verwendung der Alarmzeile in VisiWin angezeigt. Wird die Alarmbox in VisiWin benutzt, so werden bei Anwahl Systemalarme auch hier die Fehlermeldungen angezeigt. Die Texte liegen in deutscher und in englischer Sprache vor und können nicht vom Anwender geändert werden.

In einigen unten angegebenen Fehlermeldungen befindet sich ein % Zeichen. Dieses dient als Platzhalter. Zur Laufzeit, wenn der Fehler auftritt, wird anstelle des % Zeichens die Strukturadresse eingeblendet, bei der der Fehler aufgetreten ist.

Die zur Zeit anstehende Fehlermeldung im Fenster des Kommunikationstreibers bleibt so lange stehen, bis eine neue Fehlermeldung erzeugt wird. Hat der folgende Protokoll-lese oder -schreibefehl keinen Fehler mehr erzeugt, so wird die anstehende Fehlermeldung gelöscht.


Allgemeine Fehlermeldungen

Diese Fehlermeldungen gibt es bei allen Kommunikationstreibern unabhängig vom verwendeten Protokoll.

Fehlermeldung | Fehlerbeschreibung
Kein Thread erzeugt | Das Betriebssystem hat die Erstellung eines Threads, in dem die eigentliche Kommunikation abläuft abgewiesen. Eventuell hat das System keinen Speicher mehr oder ist ausgelastet.
Speicherdatei nicht geöffnet | Die speicherbasierte Datei in der der Kommunikationstreiber und der VWEKernel Daten austauscht kann nicht geöffnet werden. Der VWEKernel hat diese Datei nicht angelegt oder ist abgestürzt.
Kein Mutex für Speicherdatei | Der Verriegelungsmechanismus für den Zugriff auf die speicherbasierte Datei kann nicht erzeugt werden. Der VWEKernel hat diesen Mutex nicht angelegt oder ist abgestürzt.
Kein Zugriff auf Speicherdatei | Auf die speicherbasierte Datei kann nicht zugegriffen werden. Der VWEKernel hat diese Datei gelöscht oder ist abgestürzt.
Fehler Start Testlauf | Wird der Kommunikationstreiber im Testmodus gestartet, hat es einen Initialisierungsfehler gegeben. Beenden Sie den Testlauf und starten Sie den Kommunikationstreiber erneut.
Hilfe nicht verfügbar | Die Datei, in welcher sich die gerade aufgerufenen Hilfe befindet kann nicht im zugehörigen Pfad (Pfad des Kommunikationstreiber) gefunden werden.


Protokollspezifische Fehlermeldungen

Fehlermeldung | Fehlerbeschreibung
Objektadresse fehlerhaft %s | Tritt nur dann auf, wenn sich zur Laufzeit die Adresse geändert hat. Es kann dann keine Datenzuordung mehr erfolgen.
Mehr als 1000 externe Objekte %s | Zur Zeit kann der VWDummy Kommunikationstreiber nur 1000 Objekte verwalten. Die unter %s eingeblendeten Adressen liegen über dieser Anzahl.