VisiWinStudio-Tutorial

Einführung

VisiWinStudio-Projekt anlegen

VisualBasic-Entwicklungsumgebung

Items hinzufügen

Aufbau der Form "FCentral"

Start der Applikation


Einführung

Dieses Tutorial soll dem Benutzer den Umgang mit VisiWinStudio erläutern und Ihm anhand eines kleinen Beispielprojektes die grundlegenden Schritte zum Erstellen eines Projektes erläutern.

Hierbei werden folgende Themen behandelt:

VisiWinStudio-Projekt anlegen | Erläuterung zum Starten von VisiWinStudio und Erklärung der wichtigsten Projekteinstellungen
VisualBasic-Entwicklungsumgebung | Hier werden der Aufbau von VisualBasic und die VisiWinStudio-Komponenten erläutert
Items hinzufügen | Es wird beschrieben, wie ein neuer OPC-Server angelegt wird und wie die Items des OPC-Servers in das Projekt übernommen werden.
Aufbau der Form "FCentral" | Eine kurze Erläuterung der im Tutorial vervendeten Steuerelemente und die Parametrierung der Eigenschaften.
Start der Applikation | Beschreibung des Projektstarts und des Laufzeitverhaltens der Komponenten


VisiWinStudio-Projekt anlegen

Im folgendem werden die wichtigsten Schritte zum Anlegen des VisiWinStudio-Tutorials beschrieben.


Start

Hier wird der Programmstart und die Auswahl des Projekttyps beschrieben.


Start von VisiWinStudio

Nach der Installation ist die Entwicklungsumgebung von VisiWinStudio über das Windows-Startsymbol erreichbar.


Das Startup-Fenster

Nach dem Öffnen von VisiWinStudio erscheint das Startup-Fenster von VisiWinStudio.

Es kann sein, dass es einen Moment dauert bis das Startup-Fenster entladen wurde.


Registerkarte "Neu"

Im nun erscheinenden Fenster muss die Registerkarte "Neu" angewählt werden. Hier werden verschiedene mögliche Projekttypen zur Auswahl angeboten. Als Projekttyp für das VisiWinStudio-Tutorium sollte "Single" ausgewählt werden.

Danach kann durch Betätigen der Schaltfläche "Öffnen" fortgefahren werden.


Projekteinstellungen

Nachdem der Projekttyp ausgewählt wurde erscheint ein Fenster mit dem Titel "VisiWinStudio-Neues 'Single'-Projekt anlegen. Auf den im folgenden beschriebenen Registerkarten können die Projekteinstellungen bearbeitet werden.

Nachdem alle Eintsellungen vorgenommen wurden kann durch Betätigen der Schaltfläche "OK" die Entwicklungsumgebung von VisualBasic/VisiWinStudio gestartet werden.


Registerkarte "Allgemein"

Projektname | Als Projektname sollte, wie in der Grafik zu sehen "VisiWinStudio-Tutorial" angegeben werden.
Projektverzeichnis | Bei der Eingabe des Projektnames wird automatisch der Name des Verzeichnisses generiert, in der die Projektdateien gespeichert werden. Man kann aber auch ein anderes Verzeichnis angeben.


Registerkarte "Sprachen"

Projektsprachen | Hier sieht man die Spachen, die in VisiWinStudio verwendet werden können.
Entwicklersprache | Die Sprache, die markiert ist wird als Entwicklersprache verwendet. Sie bestimmt die Sprache der VisiWinStudio-Komponenten in der Entwicklungsoberfläche von VisualBasic. Momentan kann man hier je nach Vorliebe zwischen Deutsch und Englisch wählen.


Registerkarte "Weitere Parameter"

Designer | Falls mehrere Versionen von VisualBasic auf dem Rechner installiert sind kann man hier seine bevorzugte Version auswählen.
Version | Hier kann eine Versionsnummer für das VisiWinStudio-Tutorial angegeben werden.
Kunde | In diesem Feld kann der Kunde des Projektes angegeben werden.
Entwickler | Hier kann man seinen Namen angeben.
Kommentar | Dieses Feld dient zur Angabe eines wahlfreien Kommentars für das VisiWinStudio-Tutorial.


VisualBasic-Entwicklungsumgebung

In diesem Kapitel werden die Komponenten von VisiWinStudio und der VisualBasic-Entwicklungsumgebung beschrieben.

1 VisualBasic-Toolbar | Hier findet man die gängigsten Befehle von VisualBasic, wie zum Beispiel Öffnen, Speichern und Projekt starten.
2 VisiWinStudio-Toolbar | In der VisiWinStudio-Toolbar kann man zum Beispiel die Tools zur Konfiguration von VisiWinStudio aufrufen.
3 Formular/Code-Fenster | Hier werden entweder Formulare oder das Codefenster von VisualBasic angezeigt.
4 VisiWinStudio-Projektexplorer | Hier findet man unter anderem die im Projekt enthaltenen Formen, die VisiWinStudio-Editoren sowie die vorhandenen Kommunikationskanäle.
5 Steuerelemente | In diesem Fenster findet man sowohl die Steuerelemente von VisualBasic als auch die von VisiWinStudio zur Verfügung gestellten.
6 Eigenschaftenfenster | Hier können die Eigenschaften von Formularen und Steuerelementen angezeigt und bearbeitet werden.


Items hinzufügen

In diesem Kapitel wird das Anlegen eines neuen OPC-Servers und die Übernahme von OPC-Items in das VisiWinStudio-Tutorial beschrieben.


Neuen Kommunikationskanal anlegen

Um einen neuen Kommunikationskanal anzulegen öffnet man zuerst den Knoten "Items" im VisiWinStudio-Projektexplorer. Anschließend öffnet ein rechter Mausklick auf den Knoten "Extern" ein Popup-Menü, in dem der Eintrag "Neuer Kanal (OPC-Server)" gewählt werden muss.


OPC-Server auswählen

Es erscheint nun ein Fenster mit dem Titel "Eigenschaften: Ch1".

Nach der Betätigung der Schaltfläche mit dem Fernglas gelangt man in den Dialog zur Auswahl des OPC-Servers.

Hier wählt man den OPC-Server mit der Beschreibung "VWOPC Server Demo Machine & Simulation V1.0" aus und bestätigt die Wahl anschließend mit der "OK" Schaltfläche.

Es erscheint wieder das Fenster mit dem Titel "Eigenschaften: CH1" in dem der OPC-Server eingetragen wurde.

Dieses Fenster kann durch Betätigen der Schaltfläche "OK" geschlossen werden.


OPC-Items übernehmen

Der OPC-Server wurde nun in den VisiWinStudio-Projektexplorer übernommen. Nach einem rechten Mausklick auf den Eintrag im Projektexplorer öffnet sich ein Popup-Menü in dem der Eintrag "Browsen" ausgewählt werden muss.

Es öffnet sich nun ein Fenster mit dem Titel "Items browsen".

Man markiert hier, wie in der Grafik zu sehen den Knoten "Distillation Device" und bestätigt diese Auswahl anschließend mit der Schaltfläche "OK".

Die augewählten Items werden nun in den VisiWinStudio-Projektexplorer übernommen.


Aufbau der Form "FCentral"

In diesem Kapitel wird erläutert, wie Steuerelemente auf einer Form angelegt werden und die Eigenschaften der Steuerelemente angepasst werden.


Steuerelemente auswählen

Die Steuerelemente, die für das VisiWinStudio-Tutorial gebraucht werden sind "VWSVarOut", "VWSVarIn" und "VWS-Bar".

Die Steuerelemente sollten, wie in der Grafik zu sehen auf der Form platziert werden.

Dies geschieht folgendermaßen: Man führt zuerst einen Doppelklick auf die entsprechenden Symbole aus um die Steuerelemente in die Form zu übernehmen. Anschließen kann man die Steuerelemente auf der Form bewegen indem man die Maus über den Steuerelementen gedrückt hält und bewegt.


Eigenschaft "VW-Item"

Die Eigenschaft "VWItem" ist die wohl wichtigste Eigenschaft der VisiWinStudio-Steuerelemente. Sie enthält den Namen des OPC-Server-Items. Nach einem rechten Mausklick auf das "VWSBar"-Steuerelement öffnet sich ein Popup-Menü in dem der Eintrag "VWItem" ausgewählt werden muss.

Im nun erscheinenden Fenster sollte wie in der Grafik zu sehen das Item "FuelTank" ausgewählt werden. Die Übernahme des Items geschieht über das Betätigen der Schaltfläche "OK". Das Item "FuelTank" muss nun noch auf das "VWSVarOut"-Steuerelement übernommen werden.

Dem "VWSVarIn"-Steuerelement wird das Item "FuelPump" zugewiesen.


Weitere Eigenschaften

Die Steuerelemente "VWSVarOut" und "VWSVarIn" müssen nicht weiter angepasst werden. Beim "VWSBar" sind jedoch noch einige Änderungen vorzunehmen.

Dies geschieht folgendermaßen:

Durch Mausklick auf das Steuerelement werden dessen Eigenschaften im Eigenschaftenfenster von VisualBasic dargestellt.

Folgende Werte sollten geändert werden:

Limits=0; MaxValue=500


Start der Applikation

Dieses Kapitel beschreibt den Start der Applikation und das Laufzeitverhalten der VisiWinStudio-Steuerelemente.


Projektstart

Um das VisiWinStudio-Tutorial zu starten muss die Schaltfläche mit dem blauen Pfeil, welchen sich im VisiWinStudio-Projektexplorer befindet, betätigt werden.

Es kann sein, dass ein Dialog erscheint, in dem gefragt wird ob Änderungen an Dateien gespeichert werden sollen.Grafik

Diese Frage sollte mit der Schaltfläche "OK" bestätigt werden.

Die Applikation wird nun gestartet. Je nach Rechenleistung des Computers kann dies einige Sekunden in Anspruch nehmen.


Laufzeitverhalten

Nachdem die Form aufgerufen wurde dauert es noch ein paar Sekunden bis sich die Werte der Steuerelemente ändern.

Das Steuerelement "VWSVarOut" zeigt den Treibstoffstand des Tanks an. Gleiches gilt für das "VWSBar"-Steuerelement. Über das Steuerelement "VWSVarIn" kann der Zulauf zum Treibstofftank geöffnet bzw. geschlossen werden.

Dies geschieht folgendermaßen:

Durch die Eingabe einer 0 in das Steuerelement wird der Zulauf geschlossen und der Treibstoffstand bleibt gleich oder nimmt ab. Die Eingabe einer 1 bewirkt, dass der Zulauf geöffnet wird und der Treibstoffstand zunimmt.


Rückkehr zur Entwicklungsumgebung

Um in den Entwicklungsmodus zurückzukehren muss die Schaltfläche mit der Beschriftung "End" betätigt werden.

Herzlichen Glückwunsch!

Hiermit ist das VisiWinStudio-Tutorial abgeschlossen. Bei weiteren Fragen zur Funktionsweise von VisiWinStudio/VisualBasic stehen die Mitarbeiter der Firma INOSOFT GmbH gerne zur Verfügung.


Inhalt

VisiWinStudio-Tutorial